SSH not working 6860E VC

During a firmware upgrade from 8.7.89.R03 GA to 8.9.73.R01 GA the client closed our downtime window due to internal politics on their side and we had to revert back to the old config and stop everything that we were busy with.

The new OS was uploaded via Filezilla and we run the "reload from working no rollback timeout" command. The VC started up and we confirmed that the working dir started up with the new OS.

Then the client aborted the Upgrade and we reloaded the switch from Certified and "copy certified working make working running-directory" to revert everything back to how it was.

Now we have a problem with the SSH not working anymore.

We have disabled & enabled the SSH Ip Service and tried the aaa authentication in default & local mode. The switch can still not be accessed via SSH.

We tried removing the ssh_host_key & files, but after the reboot, still the same. The files were also not recreated.

We have 2 of these 6860E VC's in the network and we have been comparing files and configs to see what has changed, we found one file on the switch that is not working that is not present on the switch where the SSH is working. (/flash /system /hmon) Does this "hmon" file have anything to do with the SSH not working or does anyone know what this file is for or the purpose for the "hmon" file?

Any suggestion on how to fix this?

Any assistance will be welcome.